summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88be4211fed2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: gryffyn <aur@evan.mp>
+
+pkgname=python2-libformatstr-git
+_pkgname=libformatstr
+pkgver=r26.71f9ac6
+pkgrel=1
+pkgdesc="Small script to simplify format string exploitation."
+arch=('any')
+url="https://github.com/hellman/libformatstr/"
+license=("MIT")
+depends=('python2')
+makedepends=('git')
+source=("${_pkgname}"::"git+https://github.com/hellman/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_pkgname}
+ python2 setup.py install --root ${pkgdir}
+}