summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0253b0a87805..08f595f7106d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: qlonik <volodin.n at gmail dot com>
+# Contributor: qlonik <volodin.n at gmail dot com>
-pkgname=python2-meteor-ejson
-pkgver=1.0.0
+_base=meteor-ejson
+pkgname=python2-${_base}
+pkgver=1.1.0
pkgrel=1
-pkgdesc="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP."
-url="https://github.com/lyschoening/meteor-ejson-python"
-depends=('python2' 'python2-six')
-license=('MIT')
-arch=('any')
-source=("https://pypi.python.org/packages/source/m/meteor-ejson/meteor-ejson-$pkgver.tar.gz")
-md5sums=('90952e08f858e936ea6703e503c6f01c')
+pkgdesc="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP"
+url="https://github.com/lyschoening/${_base}-python"
+depends=(python2-six)
+makedepends=(python2-setuptools)
+license=(MIT)
+arch=(any)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('eb211d262f0006f3229296b71320f68b59d8a7e618e65baa8e613f874a0e6ac9cfe45e30fc73ba57c42129204c5f27a32c4b8b579527fcefd601fa1dc2844da3')
build() {
- cd "$srcdir/meteor-ejson-$pkgver"
- python2 setup.py build
+ cd ${_base}-${pkgver}
+ python2 setup.py build
}
package() {
- cd "$srcdir/meteor-ejson-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}