summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2e6bf3ff0a6..fb6b002ced5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,8 +34,8 @@ if [ -n "$VIRTUAL_ENV" ]; then
fi
pkgver() {
- cd "${_pkgname}"
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {