summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 895c9f3193c4..df803fb4817b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
-pkgver=3.7.0
+pkgver=3.8.0
pkgrel=1
pkgdesc='The CTF framework used by Gallopsled in every CTF'
arch=('any')
@@ -29,7 +29,7 @@ depends=('python2>=2.7'
conflicts=('python2-pwntools' 'python2-pwntools-git')
options=('strip')
source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz")
-sha256sums=('ebbe14a334de1d8f9c3ac7500d35f81a06b1d7d8d920ce79647340f159959f6d')
+sha256sums=('2abf4cc6b77928411c515f7b221d1414ed06b321d240f958c399e7638bc4998e')
_repodir="pwntools-${pkgver}"
@@ -41,5 +41,5 @@ package() {
cd ${srcdir}/${_repodir}
python2 setup.py install --root=${pkgdir}/ --optimize=1 --only-use-pwn-command
install -D -m 644 LICENSE-pwntools.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm ${pkgdir}/usr/lib/python*/site-packages/LICENSE-pwntools.txt ${pkgdir}/usr/lib/python*/site-packages/requirements.txt
+ rm ${pkgdir}/usr/lib/python*/site-packages/*.{txt,md}
}