summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11ed495c252c..410e43768d5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
# Maintainer: Borja Ruiz <borja [at] libcrack [dot] so>
pkgname=python2-pwntools
-pkgver=2.1.1.r18.g528e2db
+pkgver=2.2.r49.g7d964f8
pkgrel=1
-pkgdesc="CTF framework used by Gallopsled in every CTF"
+pkgdesc="The CTF framework used by Gallopsled in every CTF."
arch=('any')
url="https://github.com/Gallopsled/pwntools/"
-license=('Mostly MIT, some GPL/BSD')
-groups=()
-#depends=('python2>=2.7' 'python2-pip' 'python2-mako' 'python2-paramiko')
+license=('MIT' 'GPL2' 'BSD')
+makedepends=('lib32-glibc')
depends=('python2>=2.7' 'python2-mako' 'python2-paramiko')
-#aur/python26-argparse
-makedepends=()
provides=('python2-pwntools')
conflicts=('python2-pwntools')
replaces=('python2-pwntools')
backup=()
options=(!emptydirs)
-install=
source=("$pkgname"::'git+https://github.com/Gallopsled/pwntools.git')
md5sums=('SKIP')
@@ -30,5 +26,3 @@ package() {
python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m 644 LICENSE-pwntools.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: