summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 410e43768d5c..03f2d1bba7dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Borja Ruiz <borja [at] libcrack [dot] so>
+# Maintainer: jerry73204 <jerry73204@gmail.com>
pkgname=python2-pwntools
-pkgver=2.2.r49.g7d964f8
+pkgver=2.2.0
pkgrel=1
pkgdesc="The CTF framework used by Gallopsled in every CTF."
arch=('any')
@@ -8,21 +8,15 @@ url="https://github.com/Gallopsled/pwntools/"
license=('MIT' 'GPL2' 'BSD')
makedepends=('lib32-glibc')
depends=('python2>=2.7' 'python2-mako' 'python2-paramiko')
-provides=('python2-pwntools')
-conflicts=('python2-pwntools')
-replaces=('python2-pwntools')
-backup=()
-options=(!emptydirs)
-source=("$pkgname"::'git+https://github.com/Gallopsled/pwntools.git')
-md5sums=('SKIP')
+conflicts=('python2-pwntools', 'python2-pwntools-git')
+options=('strip')
+source=("https://github.com/Gallopsled/pwntools/archive/${pkgver}.tar.gz")
+md5sums=('3ab358401ec751436f71633fb7476c28')
-pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
-}
+_repodir="pwntools-$pkgver"
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_repodir"
python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m 644 LICENSE-pwntools.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}