summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd7e3bf45ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+_pkgname=python2-pycpa
+pkgname=$_pkgname-git
+pkgver=20200908
+pkgrel=1
+pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
+arch=('any')
+makedepends=('git')
+depends=('python2' 'python2-matplotlib' 'simpy' 'python2-setuptools' 'python2-nose' 'python2-tornado')
+provides=('python2-pycpa')
+replaces=('python2-pycpa-git')
+url="https://bitbucket.org/pycpa/pycpa/"
+license=('MIT')
+
+source=("git+https://bitbucket.org/pycpa/pycpa")
+md5sums=("SKIP")
+
+build() {
+ cd ${srcdir}/pycpa
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/pycpa
+ python2 setup.py install --root="${pkgdir}"
+}