summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab3ea972a0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+
+_pkgname=python2-pyelliptic
+pkgname=$_pkgname-git
+pkgver=69.7810c7a
+pkgrel=1
+pkgdesc="Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish..."
+arch=(any)
+url="https://github.com/yann2192/pyelliptic"
+license=('GPL3')
+depends=('openssl')
+makedepends=('git')
+source=('pyelliptic::git+https://github.com/yann2192/pyelliptic.git')
+conflicts=('python2-pyelliptic')
+
+package(){
+ cd pyelliptic
+ python2 setup.py install --root="$pkgdir"
+}
+
+pkgver() {
+ cd pyelliptic
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')