summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75ed47a1fdc3..a6f1702b6cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Maintainer : Graziano Giuliani <graziano.giuliani@gmail.com>
pkgname=python2-pygrib
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python module for reading and writing GRIB (editions 1 and 2) files."
arch=('i686' 'x86_64')
url="https://github.com/jswhit/pygrib"
license=('MIT')
-depends=('python2-pyproj' 'jasper' 'python2-numpy' 'grib_api')
-source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz)
-md5sums=('e9ae04cb987992691b388b16be53214a')
+depends=('python2-pyproj' 'jasper' 'python2-numpy' 'eccodes')
+source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz setup.cfg)
+md5sums=('e9ae04cb987992691b388b16be53214a'
+ 'd5a6f196213d2a53c280c7be1cb1bb03')
build() {
cd "${srcdir}/pygrib-${pkgver}"
@@ -18,6 +19,8 @@ build() {
export ZLIB_DIR=/usr
export OPENJPEG_DIR=/usr
export GRIBAPI_DIR=/usr
+ cp ${srcdir}/setup.cfg .
+ sed -i 's/image.inmem_.*=.*1;//' g2clib_src/enc_jpeg2000.c
python2 setup.py build
}