summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b53d1b220d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caesim404 <caesim404 at gmail dot com>
+
+pkgname=python2-pyjsparser
+_pypiname=${pkgname/python2-/}
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="Fast JavaScript parser (based on esprima.js)"
+arch=(any)
+url="https://github.com/PiotrDabkowski/pyjsparser"
+license=(MIT)
+depends=(python2)
+makedepends=(python2-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md")
+md5sums=("69a028f632baf7fe79fe2df253cbfd26"
+ "faa744092d3fb3314632e815e7c3a560")
+
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+
+ cd "${_pypiname}-${pkgver}"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}