summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2313e56a206f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+
+pkgname='python2-pytyle1-git'
+_pkgname='python2-pytyle1'
+pkgver=r30.fec5546
+pkgrel=1
+pkgdesc="An extremely versatile and extensible tiling manager that is meant
+to be embedded into EWMH window managers"
+arch=("any")
+url="https://github.com/BurntSushi/pytyle1"
+license=('GPL')
+makedepends=('git')
+depends=('python2-xlib')
+source=($_pkgname::'git+https://github.com/BurntSushi/pytyle1')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: