summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4b22da7ee9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=q
+pkgname=python2-$_pkgname
+pkgver=2.5
+pkgrel=1
+pkgdesc="Quick-and-dirty debugging output for tired programmers"
+arch=("any")
+license=("APACHE")
+url="https://github.com/zestyping/q"
+depends=("python")
+source=("http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=("d115f95058f18250faec0b7fe8a86a926939e5df215dcdbf8729906d9a34b657")
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}