summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20c076d5e595
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python2-qprogedit
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="PyQt4 widget that implements a full-featured text editor"
+arch=('i686' 'x86_64')
+url="https://github.com/smathot/QProgEdit"
+license=('GPL3')
+depends=('python2-pyqt4' 'python2-qscintilla')
+makedepends=('git')
+provides=('python2-qprogedit')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/smathot/QProgEdit.git#tag=release/2.1.0')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+
+build() {
+ cd "$srcdir/$pkgname"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}