summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba988eae838c..641d3f64e7fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
_name=rasterio
pkgname=('python2-rasterio')
-pkgver=1.0.24
+pkgver=1.1.8
pkgrel=1
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy (Python 2)"
arch=('x86_64')
url="https://github.com/mapbox/rasterio"
license=('BSD')
-makedepends=('python2-setuptools' 'cython2')
-depends=('python2-affine' 'python2-cligj' 'python2-numpy' 'python2-snuggs'
+makedepends=('cython2')
+depends=('python2-affine' 'python2-cligj>=0.5' 'python2-numpy' 'python2-snuggs'
'python2-attrs' 'python2-click'
'python2-click-plugins' 'python2-enum34' 'python2-setuptools' 'gdal')
-optdepends=('ipython2: Alternative inspector interpreter (rio insp --ipython)'
+optdepends=('ipython2: Alternative inspector interpreter (rio2 insp --ipython)'
'python2-boto3: AWS S3 raster access'
- 'python2-matplotlib: plt object (rio insp), rasterio.plot module')
+ 'python2-matplotlib: plt object (rio2 insp), rasterio.plot module')
options=(!emptydirs)
-sha256sums=('4839479621045211f66868ec49625979693450bc2e476f23e7e8ac4804eaf452')
+sha256sums=('f7cac7e2ecf65b4b1eb78c994c63bd429b67dc679b0bc0ecfe487d3d5bf88fd5')
_pypi='https://files.pythonhosted.org/packages'
-_path='57/84/be5689470a73f5f8988cf44b81cb3493ebb8abbbebb69768c8fc86fccdd5'
+_path='73/2d/3e1bc56d75bf7c4cd5df51536992b3420197f2aa5ddd4d93e12100715dff'
source=("$_pypi/$_path/$_name-$pkgver.tar.gz")
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+
+ # Rename the console script from "rio" to "rio2"
+ sed -ri 's/^(\s+rio)(=.*)/\12\2/' setup.py
+}
+
build() {
cd "$srcdir/$_name-$pkgver"
python2 setup.py build