summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..def57ede6784
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Edwin Peters <slimed13 at hotmail dot com>
+
+pkgname=python2-reedsolomon-git
+pkgver=c9ec28a
+pkgrel=1
+pkgdesc="Pure-Python Reed Solomon encoder/decoder"
+arch=('any')
+url="https://github.com/tomerfiliba/reedsolomon"
+license=('BSD')
+depends=('python2' )
+optdepends=('cython2' )
+makedepends=('python2-setuptools' 'git')
+source=(git+https://github.com/tomerfiliba/reedsolomon.git)
+sha256sums=(SKIP)
+
+package() {
+ cd ${srcdir}/reedsolomon
+
+ # ignores any LDFLAGS set in makepkg.conf
+ unset LDFLAGS
+
+ python2 ./setup.py install --root=${pkgdir}
+
+} \ No newline at end of file