summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc79f185083e..4b49df3b864c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python2-rosdep'
pkgname=('python2-rosdep')
-_module='rosdep'
pkgver='0.19.0'
-pkgrel=1
-pkgdesc="rosdep package manager abstraction tool for ROS"
-url="http://wiki.ros.org/rosdep"
+pkgrel=2
+pkgdesc='rosdep package manager abstraction tool for ROS'
+arch=('any')
+url='https://github.com/ros-infrastructure/rosdep'
+license=('BSD')
depends=('python2' 'python2-catkin_pkg' 'python2-rosdistro' 'python2-rospkg' 'python2-yaml')
-conflicts=('python-rosdep')
makedepends=('python2-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('92e5975eddd528da224b39b112a4f6539d89bd20bbbaa73ab51d43d395ce662e')
+
+conflicts=('python-rosdep')
+source=("https://github.com/ros-infrastructure/rosdep/archive/${pkgver}.tar.gz")
+sha256sums=('4497f7d220eec5d322bea95484d7bb66daeabdaec762b9095c4cf28759f3d55c')
+
+_module='rosdep'
build() {
cd "${srcdir}/${_module}-${pkgver}"