summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4cbe68c1d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: DJ Lucas <dj_AT_linuxfromscratch_DOT_org>
+_name=schema
+pkgname="python2-$_name"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='Python module to validate and convert data structures.'
+arch=('i686' 'x86_64')
+url="https://github.com/halst/$_name"
+license=('MIT')
+depends=('python')
+source=("https://pypi.python.org/packages/source/s/$_name/$_name-$pkgver.tar.gz")
+sha1sums=('732ef97af28bcc8667ab3cbb1e8c1ac2668623d4')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 {,"$pkgdir/usr/share/licenses/$pkgname/"}LICENSE-MIT
+}