summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 459fa9e60a3f..364152789d3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,20 @@
pkgname=python2-textx
_srcname=textX
pkgver=2.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python library for building Domain-Specific Languages and parsers"
arch=('any')
url="http://textx.github.io/textX/"
license=('MIT')
depends=('python2' 'python2-arpeggio' 'python2-click')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner' 'python2-pip' 'python2-jinja')
source=($pkgname-$pkgver.tar.gz::https://github.com/textX/$_srcname/archive/v$pkgver.tar.gz)
md5sums=('cc4fe6d5db278477b15afd5d349c1cda')
build() {
cd $_srcname-$pkgver
- python setup.py build
+ python2 setup.py build
}
check() {
@@ -22,23 +24,23 @@ check() {
cd $_srcname-$pkgver
# Install all tests projects
- pip install --user -e . || exit 1
- pip install --user -e tests/functional/subcommands/example_project || exit 1
- pip install --user -e tests/functional/registration/projects/types_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/data_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/flow_dsl || exit 1
- pip install --user -e tests/functional/registration/projects/flow_codegen || exit 1
+ pip2 install --user -e . || exit 1
+ pip2 install --user -e tests/functional/subcommands/example_project || exit 1
+ pip2 install --user -e tests/functional/registration/projects/types_dsl || exit 1
+ pip2 install --user -e tests/functional/registration/projects/data_dsl || exit 1
+ pip2 install --user -e tests/functional/registration/projects/flow_dsl || exit 1
+ pip2 install --user -e tests/functional/registration/projects/flow_codegen || exit 1
# Run all tests
- python setup.py pytest --addopts tests/functional
+ python2 setup.py pytest --addopts tests/functional
# Uninstall all test projects
- pip uninstall -y textX || exit 1
- pip uninstall -y textX-subcommand-test || exit 1
- pip uninstall -y types_dsl || exit 1
- pip uninstall -y data_dsl || exit 1
- pip uninstall -y flow_dsl || exit 1
- pip uninstall -y flow_codegen || exit 1
+ pip2 uninstall -y textX || exit 1
+ pip2 uninstall -y textX-subcommand-test || exit 1
+ pip2 uninstall -y types_dsl || exit 1
+ pip2 uninstall -y data_dsl || exit 1
+ pip2 uninstall -y flow_dsl || exit 1
+ pip2 uninstall -y flow_codegen || exit 1
}
package() {