summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34461aedd82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Yegorius <yegorius@domic.us>
+
+pkgname=python2-zeroconf
+_srcname=python-zeroconf
+pkgver=0.17.4
+pkgrel=1
+pkgdesc="A pure python implementation of multicast DNS service discovery"
+arch=('any')
+url="https://github.com/jstasiak/python-zeroconf"
+license=('LGPL')
+depends=('python2' 'python2-netifaces' 'python2-six')
+makedepends=('python2-setuptools')
+source=("https://github.com/jstasiak/${_srcname}/archive/${pkgver}.tar.gz")
+sha256sums=('39ea7752c0032fe22d62f6d38415f7fbd981e43e70f3980a407178b67788ebd0')
+
+package() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+