summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53853dc2bc79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: 0kalekale <kalekale.anon@gmail.com> - https://kalekale.ga
+
+pkgname=python3-anilistpy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc=""
+arch=('i686' 'x86_64')
+url="https://github.com/anilistpy/anilistpy"
+license=('AGPL2')
+provides=('python3-anilistpy')
+conflicts=('python3-anilistpy')
+makedepends=('python' 'rust' 'python-pip')
+source=('git+https://github.com/anilistpy/anilistpy.git')
+md5sums=('SKIP')
+
+prepare() {
+ pip3 install setuptools wheel setuptools-rust requests
+}
+
+build() {
+ cd anilistpy
+}
+
+package() {
+ cd anilistpy
+ python3 setup.py install --user
+}