summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceb372d77520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+_pkgbase=pytouhou
+pkgname="$_pkgbase-hg"
+pkgver=633
+pkgrel=1
+pkgdesc='Libre reimplementation of the Touhou 6 engine.'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://pytouhou.linkmauve.fr/'
+license=('GPL3')
+depends=('python' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'libepoxy' 'libgl')
+makedepends=('mercurial' 'cython')
+provides=("pytouhou=$pkgver")
+conflicts=('pytouhou')
+optdepends=('gtk3: for a graphical main menu'
+ 'th06-demo-pytouhou: the freeware demo of EoSD.')
+
+source=("$_pkgbase::hg+http://hg.linkmauve.fr/touhou")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ hg identify -n
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sts=2 sw=2 et: