summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7202f90b0c89..e7bebefb096a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
#Automatically generated by pip2arch on 2018-08-09
pkgname=pyznap
-pkgver=1.2.0
-pkgrel=3
+pkgver=1.2.1
+pkgrel=1
pkgdesc="ZFS snapshot tool written in Python"
url="https://github.com/yboetz/pyznap"
depends=('python' 'python-paramiko' )
@@ -10,7 +10,7 @@ makedepends=('python3' )
license=('GPLv3')
arch=('any')
source=("pyznap-${pkgver}.tar.gz::https://github.com/yboetz/pyznap/archive/v${pkgver}.tar.gz")
-sha256sums=('7c5b11c0dea1570cc8008188fa602b7b6a258571c07c709930bbdca708d3e944')
+sha256sums=('230efa4430bf68e080b6978e6d2c223f1c6e5401e333da2ddad0e92ccc3c2c56')
build() {
cd $srcdir/pyznap-${pkgver}
@@ -19,8 +19,5 @@ build() {
package() {
cd $srcdir/pyznap-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
-
- # Python 2.x and 3.5, configparser is *not* built in, so it is a requirement. In 3.6+, it is built in.
- sed -i '/^configparser/d' "${pkgdir}/usr/lib/python3.7/site-packages/pyznap-1.2.0-py3.7.egg-info/requires.txt"
+ python setup.py install --root="${pkgdir}" --optimize=1
}