summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 617371292afa..c20e1e7ac013 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,9 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+_stable_branch="v3_3_x"
pkgname=qbittorrent-stable-git
-pkgver=3.3.1.r0.gd753988
+pkgver=3.3.7.r2.g4da05e5
pkgrel=1
pkgdesc="An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar. Built from source."
arch=('i686' 'x86_64')
@@ -19,14 +20,22 @@ optdepends=('python: needed for torrent search tab')
provides=('qbittorrent')
conflicts=('qbittorrent')
install=${pkgname%-*-*}.install
-source=("${pkgname%-*-*}"::"git+https://github.com/qbittorrent/qBittorrent.git#branch=v3_3_x")
-sha256sums=('SKIP')
+source=("${pkgname%-*-*}"::"git+https://github.com/qbittorrent/qBittorrent.git#branch=${_stable_branch}"
+'https://github.com/evsh/qBittorrent/commit/b5775b467ba4ebda1366b8ae0ccf664cb4292272.patch')
+sha256sums=('SKIP'
+ '30084803e4609c004252f8fb346d1406ae0ad394d5efda68c74db0af2efbe437')
pkgver() {
cd $srcdir/${pkgname%-*-*}
git describe --long --tags | sed 's/^release-//;s/-/.r/;s/-/./'
}
+prepare() {
+ cd "$srcdir/${pkgname%-*-*}"
+ ## Fix bug in which log is flooded with "Network configuration has changed" messages
+ patch -Np1 -i "${srcdir}/b5775b467ba4ebda1366b8ae0ccf664cb4292272.patch"
+}
+
build() {
cd $srcdir/${pkgname%-*-*}
./configure --prefix=/usr