summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 34 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63b543d3a7ba..5390ea73b495 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,42 @@
-# Mantainer: Daniel Urdiales <daniurdi46@gmail.com>
+# Maintainer: ArcanusNEO <admin@transcliff.eu.org>
+# Contributor: Daniel Urdiales <daniurdi46@gmail.com>
+# Copyright (C) 2019 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the CC0 1.0 License.
pkgname=qdl-git
-pkgver=760b3dffb03d2b7dfb82c6eac652a092f51c572d
-pkgrel=0
-pkgdesc="This tool communicates with USB devices of id 05c6:9008 to upload a flash loader and use this to flash images"
-arch=(any)
-url="https://git.linaro.org/landing-teams/working/qualcomm/qdl.git"
-license=(GPL)
-depends=('libxml2')
-source=("git://git.linaro.org/landing-teams/working/qualcomm/qdl.git")
-sha512sums=('SKIP')
+_pkgname=qdl
+pkgver=r83.3b22df2
+pkgrel=1
+pkgdesc="Tool to communicate with Qualcomm System On a Chip bootroms to install or execute code"
+arch=('armv7h' 'i686' 'x86_64')
+url='https://github.com/andersson/qdl'
+license=('BSD3')
+depends=('libxml2' 'systemd-libs')
+provides=("qdl")
+conflicts=("qdl")
+source=("git+${url}.git")
+sha256sums=('SKIP')
-prepare() {
- cd qdl
- git reset --hard $pkgver
+pkgver() {
+ cd $srcdir/$_pkgname
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-build() {
- cd qdl
- make
+build(){
+ cd $srcdir/$_pkgname
+ make CFLAGS:="${CFLAGS} `pkg-config --cflags libxml-2.0`" LDFLAGS:="${LDFLAGS} `pkg-config --libs libxml-2.0 libudev`"
}
-package() {
- cd qdl
- make DESTDIR="$pkgdir" install
+package(){
+ cd $srcdir/$_pkgname
+ make prefix="/usr" DESTDIR="$pkgdir" install
+
+ # Package license
+ install -d "$pkgdir/usr/share/licenses/$_pkgname/"
+ install LICENSE "$pkgdir/usr/share/licenses/$_pkgname/"
+
+ # Package documentation
+ install -d "$pkgdir/usr/share/doc/$_pkgname/"
+ install README "$pkgdir/usr/share/doc/$_pkgname/"
}