summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddb14162d93d..39d13ff99dd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: myon <myon@myon98.net>
pkgname=qemu-screamer-git
-pkgver=r96011.c108debd27
-pkgrel=2
+pkgver=r99787.448771a270
+pkgrel=1
pkgdesc="QEMU PowerPC with sound support for Macintosh emulation"
arch=('x86_64')
url='https://github.com/mcayland/qemu/tree/screamer'
license=('GPL2')
-depends=('sdl2' 'libpulse' 'vte3' 'libslirp')
+depends=('sdl2' 'libpulse' 'vte3' 'libslirp' 'dtc')
makedepends=('git' 'python' 'ninja')
-source=('git+https://github.com/mcayland/qemu.git#branch=screamer')
-sha256sums=('SKIP')
+optdepends=('qemu-common: for qemu-bridge-helper')
+source=('git+https://github.com/mcayland/qemu.git#branch=screamer'
+ 'suppress-gcc13-warning.patch')
+sha256sums=('SKIP'
+ '6fe10a16301cb3e18aff8ff40e2b24b2cc91cfe523f5ccbdd3d7264a043dfbeb')
pkgver() {
cd qemu
@@ -18,7 +21,9 @@ pkgver() {
prepare() {
# git submodules?
- mkdir build
+ mkdir -p build
+ cd qemu
+ patch -Np1 -i "${srcdir}/suppress-gcc13-warning.patch"
}
build() {
@@ -31,15 +36,16 @@ build() {
--audio-drv-list=pa,sdl \
--without-default-features \
--enable-pa --enable-gtk --enable-sdl --enable-vte \
- --enable-slirp=system --enable-avx2
+ --enable-slirp --enable-avx2
make
}
package() {
- cd build
+ cd "${srcdir}/build"
install -d "${pkgdir}/usr/bin"
install qemu-system-ppc "${pkgdir}/usr/bin/qemuscreamer-system-ppc"
install -d "${pkgdir}/usr/share/qemuscreamer"
+ cd "${srcdir}/qemu"
install -m644 pc-bios/openbios-ppc "${pkgdir}/usr/share/qemuscreamer/"
install -m644 pc-bios/vgabios-stdvga.bin "${pkgdir}/usr/share/qemuscreamer/"
install -m644 pc-bios/qemu_vga.ndrv "${pkgdir}/usr/share/qemuscreamer/"