summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e50d9e7291ba..b108623099a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,12 +26,17 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python2-pyspatialite: Processing plugin'
'python2-yaml: Processing plugin')
install="$pkgname.install"
-source=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('60e0708650303f28fdfe84b555c41c18')
+source=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
+ 'https://github.com/qgis/QGIS/commit/fc6559aa053317cda8ced657c3013a0d4c6549e9.patch')
+md5sums=('60e0708650303f28fdfe84b555c41c18'
+ 'e57b70e88a0cb4e99e9fb4910b7d932d')
prepare() {
cd $pkgname-$pkgver
+ # Fix for sip 4.18
+ patch -Np1 -i ../fc6559aa053317cda8ced657c3013a0d4c6549e9.patch
+
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
sed -i 's/python /python2 /' scripts/pyuic4-wrapper.sh