summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89ec3cccd9c1..b68f4d51ed7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,15 +12,17 @@
pkgname=qgis-ltr
_pkgname=${pkgname//-ltr}
-pkgver=2.14.11
-pkgrel=2
+pkgver=2.14.12
+pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release'
url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
-depends=('qca-qt4' 'gdal' 'qtwebkit' 'qwtpolar' 'spatialindex'
- 'python2-httplib2' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
-makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
+depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
+ 'qca-qt4' 'qscintilla-qt4' 'qt4' 'qtwebkit' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
+ 'python2' 'python2-httplib2' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
+makedepends=('cmake' 'gsl' 'perl' 'txt2tags'
+ 'sip<4.19.1' 'python2-sip<4.19.1' 'pyqt4-common<4.12-4' 'python2-pyqt4<4.12-4')
optdepends=('gpsbabel: GPS Tool plugin'
'gsl: Georeferencer plugin'
'python2-jinja: MetaSearch plugin'
@@ -34,17 +36,12 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python2-yaml: Processing plugin')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2"
- "https://github.com/qgis/QGIS/commit/70f51aeedac0013247457c9274fcef746447796c.patch")
-md5sums=('a23566264a83b1a5689c5cc1710d0552'
- '45077d8f4daef8fcad0be51fa5c361e6')
+source=("https://qgis.org/downloads/$_pkgname-$pkgver.tar.bz2")
+md5sums=('b1e7709497d6229381d694fa8f3f43a3')
prepare() {
cd $_pkgname-$pkgver
- # fix build with sip 4.19
- patch -Np1 < ../70f51aeedac0013247457c9274fcef746447796c.patch
-
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
sed -i 's/python /python2 /' scripts/pyuic4-wrapper.sh