summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45dbbfa9a96e..a7ffb1155fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@
pkgbase=qgnomeplatform-git
_pkgname=QGnomePlatform
-pkgname=(qgnomeplatform-qt5-git qgnomeplatform-qt6-git)
-pkgver=0.7.0.r78.g6505fb8
+pkgname=(qgnomeplatform-qt5-git qgnomeplatform-qt6-git qgnomeplatform-common-git)
+pkgver=0.7.0.r99.gd86d6ba
pkgrel=1
pkgdesc='QPlatformTheme for a better Qt application inclusion in GNOME'
arch=(x86_64)
url='https://github.com/FedoraQt/QGnomePlatform'
license=(LGPL2.1)
makedepends=(cmake git gtk3 qt5-wayland qt6-wayland adwaita-qt5 adwaita-qt6)
+options=('!emptydirs')
source=(git+https://github.com/FedoraQt/$_pkgname.git)
sha256sums=('SKIP')
@@ -35,21 +36,36 @@ build() {
cmake --build build-qt6
}
+package_qgnomeplatform-common-git() {
+ pkgdesc='QPlatformTheme for a better Qt application inclusion in GNOME (common files)'
+ arch=(any)
+ depends=()
+ provides=(qgnomeplatform-common)
+ conflicts=(qgnomeplatform-common)
+
+ DESTDIR="destdir-common" cmake --install build-qt6
+ for f in destdir-common/usr/share/color-schemes/*; do
+ install -Dm644 "$f" "$pkgdir/usr/share/color-schemes/$f"
+ done
+}
+
package_qgnomeplatform-qt5-git() {
pkgdesc='QPlatformTheme for a better Qt5 application inclusion in GNOME'
- depends=(gtk3 qt5-wayland adwaita-qt5)
+ depends=(gtk3 qt5-wayland qt5-quickcontrols2 adwaita-qt5 qgnomeplatform-common-git)
replaces=(qgnomeplatform qgnomeplatform-git)
provides=(qgnomeplatform-qt5)
conflicts=(qgnomeplatform-qt5)
DESTDIR="$pkgdir" cmake --install build-qt5
+ rm "$pkgdir"/usr/share/color-schemes/*
}
package_qgnomeplatform-qt6-git() {
pkgdesc='QPlatformTheme for a better Qt6 application inclusion in GNOME'
- depends=(gtk3 qt6-wayland adwaita-qt6)
+ depends=(gtk3 qt6-wayland adwaita-qt6 qgnomeplatform-common-git)
provides=(qgnomeplatform-qt6)
conflicts=(qgnomeplatform-qt6)
DESTDIR="$pkgdir" cmake --install build-qt6
+ rm "$pkgdir"/usr/share/color-schemes/*
}