summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96b587b1ecc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nathan Osman <nathan@quickmediasolutions.com>
+
+pkgname='qhttpengine'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc="Simple and secure HTTP server for Qt applications"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://github.com/nitroshare/qhttpengine"
+depends=('qt5-base')
+makedepends=('cmake')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/nitroshare/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('9e35815a517c93bc566fcb138a5ab172')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}