summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60eec407b0e5..eb17cb9d3772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=qimgv
-pkgver=0.8.4
+pkgver=1.0.3+alpha+94+ge2675f13
pkgrel=1
pkgdesc="Qt5 image viewer with experimental webm playback"
-arch=(x86_64 i686 armv6h armv7h aarch64)
+arch=(x86_64 i686 armv7h aarch64)
url="https://github.com/easymodo/qimgv"
license=(GPL3)
-depends=(qt5-base qt5-imageformats qt5-svg mpv exiv2)
-makedepends=(cmake qt5-tools)
-optdepednds=('qt5-apng-plugin: animated png support'
- 'qtraw: raw images support')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz")
-sha256sums=('d416e6bc13114a8aa877951ea55fa2804d4052e9bb5821a4a7a3203daf047603')
+depends=(qt5-base qt5-imageformats qt5-svg mpv exiv2 opencv
+ glibc gcc-libs hicolor-icon-theme)
+makedepends=(git cmake qt5-tools )
+optdepends=('kimageformats: support for more image formats'
+ 'qt5-apng-plugin: animated png support'
+ 'qtraw: raw images support')
+_commit=e2675f135d6be45036f84285a68e5a079ab4f449
+source=("git+https://github.com/easymodo/qimgv.git#commit=${_commit}")
+sha256sums=('SKIP')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -d build
+pkgver() {
+ cd qimgv
+ git describe --tags | sed 's/^v//;s/-/+/g'
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ cmake -B build -S "qimgv" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
- make DESTDIR=${pkgdir} install
+ DESTDIR="$pkgdir" cmake --install build
}