summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 17 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f6093713647..4d93b566466b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,39 @@
-# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Maintainer: Pradana Aumars <paumars@protonmail.com>
pkgname=qira
-pkgver=1.1
+pkgver=1.3
pkgrel=1
pkgdesc='QEMU Interactive Runtime Analyser'
-url='https://github.com/BinaryAnalysisPlatform/qira'
+url='https://qira.me'
arch=('x86_64' 'i686')
-license=('GPL2')
-depends=('qemu' 'python2-ipaddr' 'python2-flask-socketio' 'python2-pillow' 'python2-capstone' 'python2-pydot' 'python2-pyelftools')
+license=('MIT')
+depends=('qemu' 'python2-ipaddress' 'python2-flask-socketio' 'python2-pillow' 'python2-capstone' 'python2-pydot' 'python2-pyelftools' 'python2-pip' 'python2-virtualenv' 'python2-socketio' 'python2-gevent')
makedepends=('python2-setuptools')
-source=(https://github.com/BinaryAnalysisPlatform/${pkgname}/raw/master/releases/${pkgname}-${pkgver}.tar.xz)
-sha512sums=('11ee4d9390a28825342fe9921633aad186eebe05f2aeb875378aec193e5cb62ca8807869eeb751c8f8c0d8806e33640a6ed468d274e14ebc92b935a7e358c923')
+source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::https://github.com/geohot/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('0f30169035a42f237a0711049ddbaee0')
prepare() {
- cd ${pkgname}
+ cd ${pkgname}-${pkgver}
find . -type d -print0 | xargs -0 chmod +rx
find . -type f -print0 | xargs -0 chmod +r
find . -type f -executable -print0 | xargs -0 chmod +x
}
-build() {
- cd ${pkgname}/qiradb
- python2 setup.py build
-}
-
package() {
- cd ${pkgname}
-
- pushd qiradb
- python2 setup.py install -O1 --single-version-externally-managed --root="${pkgdir}"
- popd
-
+ cd ${pkgname}-${pkgver}
+ cd qiradb
+ python2 setup.py install -O1 --root="${pkgdir}"
+ cd ..
mv qiradb/VERSION VERSION
- rm -r qiradb
+
+ sed -i "/import sys/c\import sys\nsys.path.append('/usr/lib64/python2.7/site-packages')" middleware/qira.py
install -d "${pkgdir}/opt/${pkgname}"
cp -r . "${pkgdir}/opt/${pkgname}"
install -d "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
-
- install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ virtualenv2 venv
+ source venv/bin/activate
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
}
-
-# vim: ts=2 sw=2 et: