summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 36 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7032e0efb6c..e403298072f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Akaash Suresh <https://github.com/Curry>
+# Maintainer: Serene-Arc
pkgname=qmk-git
-pkgver=0.0.29.r0.gdc3ca88
+pkgver=1.1.1.r13.gf9d3020
+_qmk_pkgver=master
pkgrel=1
pkgdesc="CLI tool for customizing supported mechanical keyboards."
arch=('any')
@@ -11,28 +12,43 @@ depends=(
'arm-none-eabi-binutils'
'arm-none-eabi-gcc'
'arm-none-eabi-newlib'
- 'avrdude'
'avr-binutils'
- 'avr-libc'
- 'python-appdirs'
- 'python-argcomplete'
- 'python-colorama'
- 'flake8'
'avr-gcc'
+ 'avr-libc'
+ 'avrdude'
'clang'
'dfu-programmer'
'dfu-util'
'diffutils'
+ 'flake8'
'gcc'
'git'
'libusb-compat'
+ 'python-dotty-dict'
+ 'python-hidapi'
+ 'python-hjson'
+ 'python-jsonschema'
+ 'python-milc'
+ 'python-pyusb'
'unzip'
'wget'
'zip'
- )
-makedepends=('python-setuptools' 'python' 'python-pip')
-source=('git+https://github.com/qmk/qmk_cli.git')
-sha256sums=('SKIP')
+)
+makedepends=(
+ 'python'
+ 'python-build'
+ 'python-pip'
+)
+conflicts=('qmk')
+provides=('qmk')
+source=(
+ 'git+https://github.com/qmk/qmk_cli.git'
+ "50-qmk.rules_${_qmk_pkgver}::https://raw.githubusercontent.com/qmk/qmk_firmware/${_qmk_pkgver}/util/udev/50-qmk.rules"
+)
+sha256sums=(
+ 'SKIP'
+ '7562201c4a1adc7f54ca09d74098dfa5c9cf6beda2a95cc508224c6dd2c3a279'
+)
pkgver() {
cd "$_branch"
@@ -40,15 +56,16 @@ pkgver() {
}
build() {
- pip install --no-deps --target="deps" yapf hjson
cd "$_branch"
- python setup.py build
+ python -m build --skip-dependency-check --wheel
}
package() {
- sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- cd "$_branch"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- cp -r $srcdir/deps/* $pkgdir/"$sitepackages"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_branch"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+ python -O -m compileall "${pkgdir}"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/lib/udev/rules.d"
+ install -Dm644 "${srcdir}/50-qmk.rules_${_qmk_pkgver}" "${pkgdir}/usr/lib/udev/rules.d/50-qmk.rules"
}