summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ed931fee86b..e404bc552796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zaps166 <spaz16@wp.pl>
pkgname=qmplay2-git
-pkgver=17.12.31
+pkgver=18.02.03
pkgrel=1
pkgdesc='QMPlay2 is a video and audio player which can play most formats and codecs'
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
@@ -12,7 +12,7 @@ optdepends=('pulseaudio: PulseAudio support'
'game_music_emu-kode54-git: Better chiptune support (less bugs in sound, AUR package)')
conflicts=('qmplay2')
provides=('qmplay2')
-makedepends=('make' 'gcc' 'git' 'pkg-config' 'qt5-tools' 'cmake' 'ccache')
+makedepends=('make' 'gcc' 'git' 'pkg-config' 'qt5-tools' 'cmake')
source=('git+https://github.com/zaps166/QMPlay2')
sha256sums=('SKIP')
@@ -26,13 +26,16 @@ build()
# Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
#USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=OFF'
- # Comment below line if you don't want to use 'jemalloc' and remove it from 'depends' list
+ # Uncomment below line if you don't want to use 'jemalloc' and remove it from 'depends' list
#USE_JEMALLOC='-DUSE_JEMALLOC=ON'
+ # Uncomment below line for ccache
+ #USE_CCACHE='-DCMAKE_CXX_COMPILER_LAUNCHER=ccache'
+
cd $srcdir
mkdir -p QMPlay2-build
cd QMPlay2-build
- cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_LINK_TIME_OPTIMIZATION=OFF -DCMAKE_CXX_COMPILER_LAUNCHER=ccache $USE_JEMALLOC $USE_SIDPLAYFP
+ cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_LINK_TIME_OPTIMIZATION=OFF $USE_CCACHE $USE_JEMALLOC $USE_SIDPLAYFP
time make
}