summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1220be16834a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+_pkgname=qotd
+pkgname=$_pkgname-git
+pkgver=0.3.0.f9827bb
+pkgrel=1
+pkgdesc="A simple QOTD (quote of the day) daemon."
+arch=('any')
+url="https://github.com/ammongit/$_pkgname"
+license=('GPL')
+depends=()
+makedepends=('git' 'gcc')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=()
+install="$pkgname.install"
+source=("git+https://github.com/ammongit/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ _ver="$(git describe --tags | sed 's/-/_/g')"
+ printf '%s.%s' "${_ver:1}" "$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
+