summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68893531b879..5ad7f611aead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * No namcap warnings or errors
-# * qperf can be built without librdmacm/libibverbs, but then has no RDMA support, and only works over TCP/IP. See package qperf-nordma
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
pkgname=qperf
pkgver=0.4.11
-pkgrel=1
-pkgdesc='OpenFabrics Alliance InfiniBand performance benchmark for bandwidth and latency'
-# Works over TCP/IP and RDMA
+pkgrel=2
+pkgdesc='OpenFabrics Alliance InfiniBand performance benchmark for bandwidth and latency (supports TCP/IP and RDMA)'
arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
-depends=('librdmacm')
+depends=('rdma-core')
conflicts=('qperf-nordma')
source=("https://github.com/linux-rdma/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('8ef6f0c0124a4eee447f39479c62a992')
+sha256sums=('b0ef2ffe050607566d06102b4ef6268aad08fdc52898620d429096e7b0767e75')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"