summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4993b3e6b10..2c460f8eacd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,19 @@
_pkgname=qps
pkgname=$_pkgname-git
pkgver=r14.3ad194f
-pkgrel=1
+pkgrel=2
pkgdesc="Qt process manager"
arch=("i686" "x86_64")
url="https://github.com/QtDesktop/qps"
license=("unknown")
-depends=("qt5-x11extras" "libxkbcommon-x11")
+depends=("qt5-x11extras" "libxkbcommon-x11" "hicolor-icon-theme")
makedepends=("git" "cmake")
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/QtDesktop/qps.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/QtDesktop/qps.git"
+ "qps.desktop")
+sha256sums=("SKIP"
+ "52396289949c2e57fb88773068c90aeb9bc6628e1f72f851d19a9dfbf3f85581")
pkgver() {
cd $_pkgname
@@ -29,4 +31,6 @@ build() {
package() {
cd build
make DESTDIR=$pkgdir install
+ install -D -m644 $startdir/qps.desktop $pkgdir/usr/share/applications/qps.desktop
+ install -D -m644 $srcdir/$_pkgname/icon/icon.xpm $pkgdir/usr/share/icons/hicolor/48x48/apps/qps.xpm
}