summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD84
1 files changed, 53 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8cd8c49421b..901d4ac6f472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+# Maintainer: Valentin Hăloiu <vially.ichb+aur@gmail.com>
+# Contributor: Riley Trautman <asonix.dev@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
@@ -6,70 +7,91 @@
_pkgname=qt5-base
pkgname=$_pkgname-git
pkgver=git
-pkgrel=1
-pkgdesc="A cross-platform application and UI framework"
+pkgrel=2
arch=("i686" "x86_64")
-url="https://qt-project.org/"
-license=("GPL3" "LGPL")
-depends=(
-"dbus" "xcb-util-keysyms" "xcb-util-wm" "xcb-util-image"
-"libxext" "inputproto" "libgl" "libxkbcommon" "systemd"
-"libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput" "qtchooser"
-)
-makedepends=("git" "postgresql-libs" "gtk2")
-optdepends=(
-"qtchooser: set the default Qt toolkit"
-"postgresql-libs: PostgreSQL driver"
-"libmariadbclient: MariaDB driver"
-"unixodbc: ODBC driver"
-"libfbclient: Firebird/iBase driver"
-)
+url='https://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc="A cross-platform application and UI framework"
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'fontconfig'
+ 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
+ 'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy')
+makedepends=('mtdev' 'libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'libpulse' 'cups' 'freetds' 'git')
+optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'mtdev: evdev plugin'
+ 'gtk3: GTK platform plugin')
provides=("$_pkgname")
conflicts=("$_pkgname" "qtchooser")
-source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=dev")
+source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=dev"
+ qtbug-55530.patch::'https://github.com/qt/qtbase/commit/f71aa4813.patch')
-sha256sums=("SKIP")
+sha256sums=('SKIP'
+ 'ea4758d296fc6af957f86858601b56829c2a04cf9adc5c4119810d341b865212')
pkgver() {
cd "$srcdir/$_pkgname"
- # cutting off 'foo-' prefix that presents in the git tag
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/$_pkgname"
- sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
- sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" "mkspecs/common/gcc-base-unix.conf"
- sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" "mkspecs/common/gcc-base.conf"
+
+ sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/gcc-base.conf
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+
+ # Use python2 for Python 2.x
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+
+ # Fix resolution of OPENSSL_LIBS
+ patch -p1 -i ../qtbug-55530.patch
}
build() {
cd "$srcdir/$_pkgname"
- ./configure -confirm-license -opensource \
+ PYTHON=/usr/bin/python2 ./configure -I/usr/include/mysql -confirm-license -opensource -v \
-prefix /usr \
- -bindir /usr/lib/qt/bin \
-docdir /usr/share/doc/qt \
-headerdir /usr/include/qt \
-archdatadir /usr/lib/qt \
-datadir /usr/share/qt \
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
-system-sqlite \
-openssl-linked \
-nomake examples \
- -nomake tests \
-no-rpath \
-optimized-qmake \
-dbus-linked \
- -reduce-relocations \
- -egl \
- -eglfs \
- -libinput
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations
+
make
}
package() {
cd "$srcdir/$_pkgname"
make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
}