summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d0f0a6d19b1..a250d72ea6de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
pkgname=qt5-graphicaleffects-git
-pkgver=5.15.1.r2.gd53af70
+pkgver=5.15.9.r0.g06cfcbb
pkgrel=1
pkgdesc="Qt5 graphical effects module"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ url="https://www.qt.io/"
license=('FDL' 'GPL' 'LGPL' 'custom')
depends=('qt5-declarative')
makedepends=('git')
-provides=('qt5-graphicaleffects')
+provides=("qt5-graphicaleffects=$pkgver")
conflicts=('qt5-graphicaleffects')
source=("git+https://code.qt.io/qt/qtgraphicaleffects.git#branch=5.15")
sha256sums=('SKIP')
@@ -28,10 +28,10 @@ prepare() {
pkgver() {
cd "qtgraphicaleffects"
- _tag=$(git tag -l --sort -v:refname | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^v5\.15[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-/_/g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-lts-lgpl//'
}
build() {