summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf9d72f81bd4..9a6843e7714a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-jsonserializer
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.1.0
+pkgrel=1
pkgdesc="A library to perform generic seralization and deserialization of QObjects"
arch=('i686' 'x86_64')
-url="https://github.com/Skycoder42/QJsonSerializer"
+url="https://github.com/Skycoder42/QtJsonSerializer"
license=('BSD')
depends=('qt5-base')
makedepends=('git' 'qt5-tools')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/QJsonSerializer.git#tag=$pkgver-2" #temporary fix for Qt 5.9.2
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=$pkgver"
"$pkgname.rule")
sha256sums=('SKIP'
'2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15')
@@ -22,7 +22,8 @@ prepare() {
build() {
cd build
- qmake -r "../$_pkgfqn/"
+ qmake "../$_pkgfqn/"
+ make qmake_all
make
}