summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7c4bd121030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nikolay Korotkiy <sikmir@gmail.com>
+_orgname=tumic0
+_pkgname=QtPBFImagePlugin
+pkgname=qt5-pbfimageplugin
+pkgver=1.1
+pkgrel=1
+pkgdesc='Qt image plugin for displaying Mapbox vector tiles'
+arch=('i686' 'x86_64')
+url='https://github.com/tumic0/QtPBFImagePlugin'
+license=('GPL3')
+depends=('qt5-base' 'protobuf')
+makedepends=('qt5-tools')
+provides=("${pkgname}=${pkgver}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/${_orgname}/${_pkgname}/archive/${pkgver}.tar.gz"
+ 'Qt5Gui_QPbfPlugin.cmake')
+sha256sums=('d12224b19fd61adef815468b7e3a6941fb193a43f7d0bd616e00e61d50a7db72'
+ 'c927c3832fe39d674c6225ad9070d3c667f1ff9d37d398669a969cdfcee1e984')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ qmake pbfplugin.pro
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ install -Dm755 libpbf.so ${pkgdir}/usr/lib/qt/plugins/imageformats/libpbf.so
+ install -Dm644 ../Qt5Gui_QPbfPlugin.cmake ${pkgdir}/usr/lib/cmake/Qt5Gui/Qt5Gui_QPbfPlugin.cmake
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}