summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 187c8c550f61..0dddbd926b45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.0.1
+_qtver=6.0.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
@@ -21,8 +21,17 @@ groups=(qt6)
conflicts=(qt6-base)
provides=(qt6-base)
_pkgfn="qtbase-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz")
-sha256sums=('8d2bc1829c1479e539f66c2f51a7e11c38a595c9e8b8e45a3b45f3cb41c6d6aa')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz"
+ qt6-base-cflags.patch
+ qt6-base-nostrip.patch)
+sha256sums=('991a0e4e123104e76563067fcfa58602050c03aba8c8bb0c6198347c707817f1'
+ 'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
+ '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
+
+prepare() {
+ patch -d $_pkgfn -p1 -i ../qt6-base-cflags.patch # Use system CFLAGS
+ patch -d $_pkgfn -p1 -i ../qt6-base-nostrip.patch # Don't strip binaries with qmake
+}
build() {
cmake -G Ninja -B build -S "$_pkgfn" \
@@ -36,13 +45,14 @@ build() {
-DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
-DQT_FEATURE_journald=ON \
-DQT_FEATURE_openssl_linked=ON \
+ -DQT_FEATURE_system_sqlite=ON \
\
-DQT_FEATURE_gui=OFF \
-DQT_FEATURE_widgets=OFF \
-DQT_FEATURE_freetype=OFF \
-DQT_FEATURE_harfbuzz=OFF
- cmake --build build --parallel
+ cmake --build build
}
package() {