summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b38ccf9e50d..48da46528719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeff_WuYo <62562200+Jeff-WuYo@users.noreply.github.com>
pkgname=qt6gtk2
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc='GTK+2.0 integration plugins for Qt6'
arch=('any')
groups=('therepoclub')
@@ -10,8 +10,10 @@ license=(GPL2)
conflicts=($pkgname-git)
depends=(qt6-svg qt6-base gtk2)
makedepends=(qt6-tools)
-source=("${pkgname}-$pkgver.tar.gz::${url}/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('22596853eb3ea663d8f28fb40d97195428b883ec571365ce1b03437f5c75f6bc')
+source=("${pkgname}-$pkgver.tar.gz::${url}/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+ "${pkgname}.hook")
+sha256sums=('22596853eb3ea663d8f28fb40d97195428b883ec571365ce1b03437f5c75f6bc'
+ '9c60620868ce7dc469985cdde56332e28ce9f60dd13d6dfa516e8d1ef94c7673')
build() {
cd $pkgname-$pkgver
@@ -23,4 +25,5 @@ package() {
cd $pkgname-$pkgver
make INSTALL_ROOT="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "$srcdir/${pkgname}.hook" "$pkgdir/usr/share/libalpm/hooks/90-${pkgname}.hook"
}