summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba35b86a48fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=qtav-git
+pkgver=v1.12.0.r99.g65483f53
+pkgrel=1
+pkgdesc="A cross-platform multimedia playback framework based on Qt and FFmpeg"
+arch=('x86_64')
+url="http://www.qtav.org/"
+license=('LGPL')
+conflicts=('qtav')
+provides=('qtav')
+depends=('qt5-declarative' 'ffmpeg' 'libxv' 'openal' 'uchardet' 'desktop-file-utils'
+ 'qt5-quickcontrols' 'qt5-svg')
+source=("git+https://github.com/wang-bin/QtAV.git")
+sha512sums=('SKIP')
+
+pkgver(){
+ cd "QtAV"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+build() {
+ cd $srcdir/QtAV
+
+ qmake-qt5 "CONFIG+=no_rpath recheck"
+ make
+}
+
+package() {
+ cd $srcdir/QtAV
+
+ make INSTALL_ROOT="${pkgdir}" install
+}