summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b19823ec9304..b38010359d62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_reponame=qtutilities
pkgname=qtutilities
-pkgver=6.0.6
+pkgver=6.1.0
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models'
@@ -15,7 +15,7 @@ makedepends=('cmake' 'qt5-tools' 'mesa')
optdepends=("$pkgname-doc: API documentation")
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('6e853502cc3a636d82e64f23e96050f8357f2937bca35ef3359c2ec75e8fedf3')
+sha256sums=('e060b4131e3193a7d72e6b4f4c70a19fddb3033c9e193dd87bc3381b265305bc')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
@@ -27,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame}"
+ make QT_QPA_PLATFORM=offscreen check
+}
+
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
make DESTDIR="${pkgdir}" install