summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f951ec5e61a1..3b953b9ee30b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,27 @@
pkgname=qtwebbrowser
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Browser for embedded devices developed using the capabilities of Qt and Qt WebEngine"
arch=('i686' 'x86_64')
url="http://doc.qt.io/QtWebBrowser"
license=('GPL3')
-makedepends=('cmake' 'git' 'qt5-webengine')
-depends=('qt5-virtualkeyboard' 'qt5-quickcontrols' 'qt5-graphicaleffects')
-source=($pkgname-$pkgver::git://code.qt.io/qt-apps/$pkgname.git#tag=v$pkgver)
-md5sums=('SKIP')
+makedepends=('git')
+depends=('qt5-webengine' 'qt5-virtualkeyboard' 'qt5-quickcontrols' 'qt5-graphicaleffects')
+source=(git://code.qt.io/qt-apps/$pkgname.git#tag=v$pkgver $pkgname.desktop)
+md5sums=('SKIP'
+ 'b1fde5cdcb9b7160398a78ecd8d70bf5')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
qmake-qt5 $pkgname.pro
make
}
package() {
- cd $pkgname-$pkgver/src
+ cd $pkgname/src
install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ install -Dm644 qml/assets/icons/AppLogoColor.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $srcdir/$pkgname.desktop /$pkgdir/usr/share/applications/$pkgname.desktop
}