summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c98ef0fc3c7..b526bfe17a94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=quake3-excessiveplus
-pkgver=2.2b
+pkgver=2.3
pkgrel=1
pkgdesc="Excessive Plus is a modification for Quake 3 where all weapons are 'excessive'."
url="http://www.excessiveplus.net/"
@@ -9,22 +9,18 @@ arch=('any')
license=('custom')
depends=('quake3')
source=("http://www.excessiveplus.net/files/release/xp-${pkgver}.zip")
-md5sums=('72a288aef8bfee1bcca782702e40495c')
+sha256sums=('213adbd718be00c49a6cdc539b0372f99703042d7afa3a6c31740a3bc7e06820')
noextract=("xp-${pkgver}.zip")
-build() {
- cd $srcdir
-}
-
package() {
- cd $srcdir
+ cd "${srcdir}"
# Base Excessive Plus Files
- install -d $pkgdir/opt/quake3/
- unzip xp-${pkgver}.zip -d $pkgdir/opt/quake3/
+ install -d "${pkgdir}/opt/quake3/"
+ unzip "xp-${pkgver}.zip" -d "${pkgdir}/opt/quake3/"
# Cleanup unneeded files
- cd $pkgdir/opt/quake3/
+ cd "${pkgdir}/opt/quake3/"
rm xp_dedicated.bat xp_server.bat xp_singleplayer.bat
rm -r excessiveplus/tools/
}