summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5157ec2d079..0724831eed8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Contributor: Slash <demodevil5[at]yahoo[dot]com>
pkgname=quake3-excessiveplus
-pkgver=2.0a
+pkgver=2.2a
pkgrel=1
pkgdesc="Excessive Plus is a modification for Quake 3 where all weapons are 'excessive'."
url="http://www.excessiveplus.net/"
-arch=('i686' 'x86_64')
+arch=('any')
license=('custom')
depends=('quake3')
source=("http://www.excessiveplus.net/files/release/xp-${pkgver}.zip")
-md5sums=('234052d4ee31b0871cb8b1d9a896d1b2')
+md5sums=('4a152dbb155f4d2848361aba3936eb45')
+noextract=("xp-${pkgver}.zip")
build() {
- cd $srcdir
+ cd $srcdir
+}
+
+package() {
+ cd $srcdir
- # Base Excessive Plus Files
- install -d $pkgdir/opt/quake3/
- unzip xp-${pkgver}.zip -d $pkgdir/opt/quake3/
+ # Base Excessive Plus Files
+ install -d $pkgdir/opt/quake3/
+ unzip xp-${pkgver}.zip -d $pkgdir/opt/quake3/
- # Cleanup unneeded files
- cd $pkgdir/opt/quake3/
- rm xp_dedicated.bat xp_server.bat xp_singleplayer.bat
- cd excessiveplus/
- rm -r tools/
+ # Cleanup unneeded files
+ cd $pkgdir/opt/quake3/
+ rm xp_dedicated.bat xp_server.bat xp_singleplayer.bat
+ rm -r excessiveplus/tools/
}