summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28553c4d2512..6c3d0b15284f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=quake3-osp
pkgver=1.03a
pkgrel=3
pkgdesc="Orange Smoothie Productions (OSP) is a modification for Quake 3 that adds many client and server features while still being compatable with the stock game."
-url="http://www.orangesmoothie.org/"
+url="https://www.orangesmoothie.org/"
license=('custom')
arch=('any')
depends=('quake3')
-source=("http://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-${pkgver}_full.zip")
-md5sums=('8b2b4925cce1895067bc617b86c62ea5')
+makedepends=('unzip')
+source=("https://osp.dget.cc/orangesmoothie/downloads/osp-Quake3-${pkgver}_full.zip")
+sha512sums=('9a9bc76ca2e582432e0f8ff6a3fe0bd2e0b0767a1f52bdea8debc7bc9053dc78951335da085b88e0f3690f1f7fda25a628cff9bace7f683f543c5eff90307e19')
noextract=("osp-Quake3-${pkgver}_full.zip")
package() {
- cd ${srcdir};
+ cd "${srcdir}";
- # Base OSP Files
- install -d ${pkgdir}/opt/quake3/
- unzip osp-Quake3-1.03a_full.zip -d ${pkgdir}/opt/quake3/
+ install -d "${pkgdir}/opt/quake3/";
+
+ # Extract base OSP files
+ unzip osp-Quake3-1.03a_full.zip -d "${pkgdir}/opt/quake3/"
+
+ # Correct directory and file permissions
+ find "${pkgdir}/opt/quake3/" \! -perm 644 -type f -exec chmod -v 644 {} \;
+ find "${pkgdir}/opt/quake3/" \! -perm 755 -type d -exec chmod -v 755 {} \;
}