summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c834dfa9936e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nick Boughton (nicholboughton@gmail.com)
+
+pkgname=quasar-cli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='CLI management tool for development with the Quasar framework'
+arch=(i686 x86_64)
+url=https://quasar.dev
+license=(MIT)
+depends=('nodejs>=8.9.0')
+makedepends=('npm>=5.0.0')
+optdepends=('npm: JS package management support')
+conflicts=()
+options=(!strip)
+
+package() {
+ npm install -g --prefix="$pkgdir"/usr @quasar/cli@$pkgver
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+}