summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8eb4314171a9..5f30edd6d0ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=("i386" "x86_64")
url="https://www.quickapp.cn/docCenter/IDEPublicity"
license=('custom')
groups=()
-depends=()
+depends=(fontconfig libxtst gtk3 python cairo alsa-lib nss gcc-libs libnotify libxss 'glibc>=2.28-4' lsof which)
makedepends=()
optdepends=()
provides=()
@@ -17,9 +17,13 @@ backup=()
options=()
install=
changelog=
-source=("https://statres.quickapp.cn/quickapp/ide/${pkgname}-${pkgver}.deb")
+source=(
+ "https://statres.quickapp.cn/quickapp/ide/${pkgname}-${pkgver}.deb"
+ "https://statres.quickapp.cn/quickapp/quickapp/201809/file/201809171830002525474.docx"
+)
noextract=()
-md5sums=('22a380224d2d50b7b2d0f206cc6850e2')
+md5sums=('22a380224d2d50b7b2d0f206cc6850e2'
+ '8d634c0f6d214e6cbacdae6b94f3ddae')
prepare() {
ar -x ${pkgname}-${pkgver}.deb
@@ -28,6 +32,7 @@ prepare() {
}
package() {
+ install -Dm 644 201809171830002525474.docx "$pkgdir/usr/share/licenses/$pkgname/LICENSE.docx"
cd "$pkgname-$pkgver"
# install -d opt/quickAppIDE
# cp opt/quickAppIDE ${pkgdir}